Update WordPress: WordPress Versions Supported by AIOSEO

If you were linked to this page from your WordPress dashboard, then it means that you’re running an outdated version of WordPress.

WordPress runs a huge percentage of all the sites on the web. Because of WordPress’s success, it’s also a target for hackers. The version that is currently used for your site is either insecure or no longer supported.

Newer versions of WordPress are both faster and more secure. In fact, the version of WordPress your website is so old it may not be receiving automatic security updates anymore, which is why we sent you the notice.

Frequently Asked Questions

Which version should I update to?

You should update your WordPress version to the latest version, or at least to WordPress 5.3.
AIOSEO will be discontinuing support for WordPress versions older than version 5.3 by the end of 2021.

How do I update WordPress?

Updating WordPress itself for most hosts is a simple process that can be done in under a minute by following this excellent step by step guide from IsItWP.

I’m Still Not Convinced, Why Should I Update WordPress?

Please see WPBeginner’s guide on this matter: Why you should always use the latest version of WordPress.